Abipy installation problem

Dear ones
After compiling and installing abinit, I started to install abipy. According to the installation instructions, everything was smooth without error. However, after the installation was completed, an error occurred during operation. The error is printed as follows,I tried some methods, including other installation methods, but they didn’t solve the problem. Can anyone help me see what the problem is?

Best wishes.
exec(compile(f.read(), file, ‘exec’))

  • File “/home/jkend/下载/abipy/abipy/scripts/abistruct.py”, line 16, in <m*
  • from abipy import abilab*
  • File “/home/jkend/.local/lib/python3.8/site-packages/abipy/init.py”,*
  • line 18, in *
  • from abipy.core import release*
  • File "/home/jkend/.local/lib/python3.8/site-packages/abipy/core/_init*
    _.py", line 4, in
  • from .structure import **
  • File "/home/jkend/.local/lib/python3.8/site-packages/abipy/core/structu*
    re.py", line 24, in
  • from abipy.flowtk import PseudoTable*
  • File “/home/jkend/.local/lib/python3.8/site-packages/abipy/flowtk/init*
    .py”, line 13, in *
  • from .tasks import **
  • File "/home/jkend/.local/lib/python3.8/site-packages/abipy/flowtk/tasks*
    .py", line 30, in
  • from . import abiinspect*
  • File "/home/jkend/.local/lib/python3.8/site-packages/ab*

Hi Zhao,

your error message seems incomplete, could you make sure you copy-paste it fully? Also would it be possible to have a minimal working example that create the same problem? Or join the script you were trying to run?



There was an incompatibility with pymatgen that was causing the ImportError.
I’ve just released Abipy v0.9.2 that fixes this problem.

You can install the new version with:

pip install abipy -U

Hi@gmatteo @fgoudreault .
Thank your for your help!
When I checked the error, I guessed that it was the problem of working concurrently with pymatgen, because I was installing the beta version of abipy, which requires the version of relevant supporting software. I went to the pymatgen website and downloaded the latest version of 2021 required by the beta version, but it still couldn’t run normally. However, I tried the simplest way is to delete the folder generated by the stable version I installed according to the installation instructions, and it can run normally. I guess it is due to the error that the software cannot read the parameters correctly when running due to multiple paths.