Can't choose with_fft_flavor="none" in config ac9 file

Trying to build abinit 9.6.2

I want to use “none” for with_fft_flavor. And here is the relevant section of the ac9 template:

# -------------------------------------------------------------------------- #
# Optimized FFT support                                                      #
# -------------------------------------------------------------------------- #
# Supported libraries:
#   * auto          : select library depending on build environment (default)
#   * custom        : bypass build-system checks
#   * dfti          : native MKL FFT library
#   * fftw3         : serial FFTW3 library
#   * fftw3-threads : threaded FFTW3 library
#   * pfft          : MPI-parallel PFFT library (for maintainers only)
#   * goedecker     : Abinit internal FFT

However, when I set with_fft_flavor=“geodecker” in my ac9 config file, I get this error when I “make”:

 === Optimized FFT support                                                  ===
checking which FFT flavors to enable... dfti goedecker
configure: WARNING: MKL is incompatible with FFTW3
                    Please use DFTI instead and consult
                    If you set the FFT flavor to fftw3, the configure script
                    will abort. Otherwise, your FFTW3 settings will be ignored.
configure: error: invalid FFT flavor: 'geodecker'

When I try with_fft_flavor=“none”, I get the same error except the last line is:
configure: error: invalid FFT flavor: ‘none’

I got around this by eliminating the dfti option in the configure file by commenting these lines:

  ## Prepend DFTI if linear algebra is MKL
  #if test "${tmp_linalg_has_mkl}" != ""; then
  #  sd_fft_selected_flavors="dfti ${sd_fft_selected_flavors}"

But I wonder what the valid choices are for with_fft_option, and specifically, I want to know how to choose “geodecker”


Without reference to with_fft_* options in the ac9 file, the Build System chosen goedecker

Actually, the build system will prefer dfti and pfft if it finds them and choose them before geodecker.

But how do I reference with_fft_flavor in the ac9 file like I wrote? I tried both with_fft_flavor=“none” and with_fft_flavor=“geodecker”, but both options produced errors at make time.

little typo in with_fft_flavor=“geodecker”

try with : with_fft_flavor=“goedecker”

In the end a simple fix. That did it!