Error dhpev returned info !=0

Dear all abiniter ,
I faced this error which might be due to abinit itself :
src_file: abi_xhpev.f90
src_line: 105
mpi_rank: 7
message: |
dhpev returned info!=0


Thank you very for for any help
with best

Hi, this code is indicating an error return in a linear algebra matrix diagonalization routine called by abinit, but without any other context it’s impossible to say why this is occurring in your run. You need to post something about your input file and output files so we can see where this error is occurring.

Hi ,
I was about making crystal optimisation of the following system:

  • one layer of cobalt above one layer of graphen ( seperation token 3.7 u.a. ) ,
    I want to calculat the acell and position of the atom in relaxation
    I attached the input file , output file noting interesting
    Cobalt_graphene.abi (3.6 KB)

Hi Abdullah,

Could you attach the pseudos as well so we can try to reproduce the problem?
Thank you!

Dear all,
I am still a beginner (all of us were at certain moment)
I attached the pseudo potential files
I was working on it since few days: I tried several ionmov values first (to optimize some parameters individually) , I turn on, off the checkdelatmax and I used restartxf -2 to contunue previous calculations .

Dear Abdullah,

I have tried to run a calculation with your files on a single processor and the Lbfgs routine fails at some point in the run.
What I can recommend for the moment is to use ionmov 2 instead of 22 in order to continue with your calculations. I have successfully ran a calculation just by replacing ionmov value to 2, again on a single processor.
Please let me know if the problem persist either in a serial or a parallel run.