Error in compiling 8.10.3 (m_polynomial_coeff)

I run UBUNTU 20.04, ABINIT 8.10.3 (downloaded from,

Was using GNU Fortran 10.3 to build ABINIT and failed at very early stage. Then switch GNU Fortran to 9.4 and still failed at a later stage after building for a while.

Error is related to /src/78_effpot/m_polynomial_coeff.F90. Looks like it is similar to another post here: Error in compiling 8.10.3 (m_polynomial_coeff) - ABINIT Discussion Forums

Can anyone shed some light what should I do? I only see Fortran 10 and 9 in my system. I’m a newbie to ABINIT so need your step by step instructions. Thank you thank you.


ABINIT 8.10.3 is a very old version.

For an easier compilation and a significantly better user experience, we highly recommend you to download ABINIT 9.6.2 instead:

I also tried to compiler ABINIT 9.6.2 with wannier90 and zpack. It didn’t work out at all. Does any one have instructions how to make ABINIT 9.6.2 with wannier90 and zpack??

Thank you

Did you start from the config template?


Hi e3uydl,

Could you provide us with the .ac9 file you are using, along with the config.log file generated after compiling? We need more information to be able to assist you. Does the build also fails at the same place with version 9.6.2?

Please find .ac and config.log that I used in Abinit 8.10.3… (80 Bytes)
config.log (128.3 KB)

For version 9.6.2, it failed at different place. I was trying to get z2pack/wannier90 working in one of the Abinit version. However, neither 9.6.2 or 8.10.3 works here.

I was trying to build z2pack / wannier90 with one abinit version so I have my own ac or ac9 file.