Error when compiling abinit-9.4.0 fallbacks

Dear developers,

I got an error message when compiling abinit-9.4.0 fallbacks, and it told me to “contact Abinit’s team” (see below). Do you have any ideas what is wrong? Thanks in advance!

Best regards,
Bo

Patching output file 1053/1055
Patching output file 1054/1055
Patching output file 1055/1055
lookup cache used 2225/65536 hits=12771 misses=2315
finished…
touch .docgen-stamp
cd developers/latex && make all
make[6]: Entering directory `/home/bp432/abinit-9.4.0/fallbacks/abinit-fallbacks-9.2/sources/xmlf90-1.5.3.1/tmp-build/doc/developers/latex’
rm -f *.ps *.dvi *.aux *.toc *.idx *.ind *.ilg *.log *.out *.brf *.blg *.bbl refman.pdf
pdflatex refman
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013)
restricted \write18 enabled.
entering extended mode
(./refman.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, lo
aded.

make[6]: *** [refman.pdf] Error 1
make[6]: Leaving directory /home/bp432/abinit-9.4.0/fallbacks/abinit-fallbacks-9.2/sources/xmlf90-1.5.3.1/tmp-build/doc/developers/latex' make[5]: *** [.docgen-latex-stamp] Error 2 make[5]: Leaving directory /home/bp432/abinit-9.4.0/fallbacks/abinit-fallbacks-9.2/sources/xmlf90-1.5.3.1/tmp-build/doc’
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory /home/bp432/abinit-9.4.0/fallbacks/abinit-fallbacks-9.2/sources/xmlf90-1.5.3.1/tmp-build/doc' make[3]: *** [all-recursive] Error 1 make[3]: Leaving directory /home/bp432/abinit-9.4.0/fallbacks/abinit-fallbacks-9.2/sources/xmlf90-1.5.3.1/tmp-build’
make[2]: *** [stamps/xmlf90-build-stamp] Error 2
make[2]: Leaving directory /home/bp432/abinit-9.4.0/fallbacks/abinit-fallbacks-9.2' make[1]: [all-local] Error 2 (ignored) Checking build of xmlf90 fallback test -e stamps/xmlf90-install-stamp make[1]: *** [all-local] Error 1 make[1]: Leaving directory /home/bp432/abinit-9.4.0/fallbacks/abinit-fallbacks-9.2’
make: *** [install-recursive] Error 1
We have detected a problem while generating fallbacks : contact Abinit’s team

Hello,

there is obviously a problem with the generation of the XMLF90 v1.5.3.1 fallback doc
Neither of the two necessary software ( Latex and doxygen ) was installed on our testfarm builders :confused:
They could not have reported this bug… :confused:

in the XMLF90 v1.5.4.0 version, the doc is no longer generated by default… :wink:

I will generate a new tarball soon.

in the meantime, if you don’t need this lib, you can add in the script “fallbacks/build-abinit-fallbacks.sh”,
these 2 lines :

–disable-atompaw
–disable-wannier90
*–disable-xmlf90
–disabled-libpsml *

LIBS_NETCDF4_FORTRAN="-ldl -lm -lz" \

and restart the build :

rm -rf abinit-fallbacks-9.2
./build-abinit-fallbacks.sh

jmb