Error while configurering abinit.9.0.4

Dear Abinit User

I have error while configuring the abinit.9.0.4.

…/configure --with-config-file=‘my_config_file.ac9’ > log
./my_config_file.ac9: line 334: abinit_moddir: command not found
configure: WARNING: forcing MPI level to 2 might make the build fail
configure: WARNING: Fortran file extension could not be changed
configure: WARNING: some advanced Fortran tests may fail
configure: error: in /home/dprai/Installed_Software/abinit-9.0.4/build': configure: error: unable to compile a simple Fortran module See config.log’ for more details
config.log (65.4 KB)
config.log (65.4 KB)


It seems that there is a problem in your ac9 config file and/or with the environment…

I see in the log that you use “-fallow-argument-mismatch” option but it not usable with gnu 8

Can you sent me the my_config-file.ac9 file ?
and the output of the command : env


A possible mistake in your .ac9 file might be some space characters around an equal sign. There must be none, because this file must be readable by a shell script.

Another possibility is that pointed by @jmbgmx : if you set wrong Fortran flags, the Fortran compiler will not be detected correctly. By policy, the configure script is forced to continue, even if it should fail telling you that the Fortran compiler is broken.

Dear Sir

Here is the my_config-file.ac9
my_config_file.ac9 (37.3 KB)


Have you read the docs on how to install abinit under ubuntu?
cfr :

There are not only inconsistencies in your ac9 file but also some syntax errors…
At first, you don’t need to configure all the variables…

If all dependencies are well installed with apt ( HDF5 / Netcdf / libXC / lapack / blas libraries and MPI libraries for parallel ), a “minimal” ac9 file looks like :

# MPI settings

# linear algebra settings
LINALG_LIBS="-L/usr/lib/x86_64-linux-gnu -llapack -lblas"

# mandatory libraries