Optical properties

Dear Sir/Madam at Abinit Group,

I hope this message finds you well.

I am a MSC student at the University of Duhok (UoD)/College of Science/Physics Department. I am a newbie in using Abinit. I have successfully run some of the tutorials on the Abinit website. But unfortunately I have the following error messages from running the Optical tutorials. It is worth mentioning that I use V8 and V9 of the software and I got the same errors and this is somehow not funny. So, it would be appreciated if you could please advise accordingly. I have also attached the necessary files for your convenience.

So, when I run the package, I got a reasonable file ‘toptic_1o_DS3_WFK’ , ‘toptic_1o_DS4_1WF16’ , ‘toptic_1o_DS5_1WF17’ and ‘toptic_1o_DS6_1WF18’ after executing “abinit toptic_1.abi > log 2> err”, but I encountered an unreasonable error when executing “optic toptic_2.abi > log 2> err &” as follows:

– !ERROR
src_file: m_invars1.F90
src_line: 324
mpi_rank: 0
message: |
Input natom must be defined, but was absent for dataset 0
Action: check the input file.

abinit_abort: decision taken to exit. Check above messages for more info

MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 14.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.

inputfiles of toptic_1.abi and toptic_2.abi

I look forward to hearing from you in the near future. Many thanks for your time and kind help.

Hi zozan,
The error message says that the flag natom is missing. Have you specified the number of atoms in the first data set?

Can you share your input file?

1 Like

Hello zozan,

I tried the tutorial you mentioned with ABINIT 9.6.2, and the first two files ran smoothly without errors. I think you might’ve used the command abinit toptic_2.abi while the correct one should be optic toptic_2.abi.

The toptic_2.abi file is an optic input file, you need optic to handle it. The main executable abinit will treat it as a standard abinit input file and try to find natom, which isn’t there, causing the error you’ve encountered.