Positron Doppler calculation fails after SCF steps

Hai all
Nice to work with latest v9.4.2.
But I have problem for positron calculations with v9.4.2.

system is W super cell with 127 atoms + 1 vacancy.
relaxation with positron and positron lifetime calculations are fine.
But doppler calculation fails after completing both electron and positron SCFs
please see attached log and input files

Mem: 132124428k total shared by 24cpus

ps: I am able to calculate doppler for 16 atoms super cell.
currently trying with 8cpu run to see if failure is due to memory requirement

looking for some clues to move forward

W_444_1V_unrelaxed_db.abi (9.1 KB)

W_444_1V_unrelaxed_db.log (496.0 KB)

Hello Rajaraman,

Any updates on your memory tests?
What happens if you set your stack limit to unlimited while maintaining your ~130GB of memory requested for the job, i.e. including this line in your job submission file:

ulimit -s unlimited



Dear Bogdan,
Thanks for your suggestion.
I added ulimit line to the job script.

will get back with its outcome.


Dear Bogdan,

Thanks a lot for the suggestion to use
ulimit -s unlimited

it worked.
though 39 SCFs took about 9hrs, Doppler calculation took additional 67hrs!
see attached log.

db.log (918.5 KB)

There was another bottleneck.
I needed optforces switch “on” for smooth switching from electronic SCFs to positron SCFs.
optforces 1

without “optforce” job fails at the start of positron SCFs
see failed job log.

db-fail_no_optforce.log (375.9 KB)

though it is ok as long as jobs complete, but the optforce is redundant when we do doppler calculations
Positron - abinit (tpositron_5 or 6)


Dear Rajaraman,

I am glad this solution worked fine for you.

I suspect it might still be a memory related problem, but I will have to ask someone well-versed in this aspect.

For the future, I might suggest to add -fbacktrace to your FLAGS when compiling ABINIT because at this stage I can’t reproduce your error.
Please let me know of the outcome if you pursue this.


Thank you Bogdan.

I am about to recompile as the output of the completed run showed only NAN.

I will include “backtrace” flag now.

I dont see any such switch to add -fbacktrace.

how to put it during compilation?