Test of the new variables write_files

Dear all,

During the last Abinit hackaton, Bogdan, Augustin, Aloïs and I have designed a new “meta” variable that will take care of the Abinit file writting.
This variable is write_files.

Could everyone play with this variable to get feedbacks and improvement before making it official and possibly remove most (if not all) prt input variables (we’ll keep it internal only at first)?
You could start by using this write_files variables instead of the prt ones to start with?
Do not hesitate to comment on anything, the format, bugs, documentation, etc, I will collect everything to get converged and optimal behavior.

Thank you and best wishes,

Hi Eric,

does this variable overrides the others? For instance, I easily imagine being able to just add “write_files none” when debugging in the input file to suppress all file writings even though other prt variables are present. Also, if you want multiple options, are they just separated by a comma? it is not clear from the docs e.g.: 'write_files den_1, dddb, …"



Hi Felix,

write_files takes precedence over individual prt*.
I noticed there are potentially a couple of buggy situation which I will correct soon, but if the users are acting bona fide those issues shouldn’t be triggered.

As for the separation, it is not properly documented indeed. This will be corrected. One can simply comma separate the options they need active, but this is not enforced in any way actually so you can even write a long string
“den_1dos_1ddb” etc. although it might become difficult to follow from the human point-of-view.
There is also a test file as example with some different situations: v9/t150.abi

Looking forward further feedback,

1 Like