Wannier90 is not working

Dear ABINIT developer,

Could some one please help me to figure out to compile abinit using Wannier90.

I am using abinit v9.6.1 on ubuntu 18.04.

Here I attach the config.log file. and the config.ac9.

Thanks a lot for the help in advance.

BTW, I am not allowed to attach file as a new user (this is what it says!), therefore I append the last message here.

The following summary table indicates the status of the feature triggers,
whether they are available and working, how they have been initialized
and whether there are fallbacks to substitute broken ones.

±---------------±-------±-------±-------±-------+
|Feature |Enabled |Init |Working |Fallback|
±---------------±-------±-------±-------±-------+
|abinit_common |no |def |unknown |no |
|bigdft |no |def |unknown |disabled|
|fft |yes |kwd |yes |no |
|fftw3 |yes |env |yes |no |
|gpu |no |def |no |no |
|hdf5 |yes |dir |yes |disabled|
|levmar |no |def |unknown |no |
|libpaw |no |def |unknown |no |
|libpsml |no |def |unknown |disabled|
|libxc |yes |dir |yes |disabled|
|libxml2 |no |def |unknown |no |
|linalg |yes |env |yes |disabled|
|mpi |yes |dir |yes |no |
|netcdf |yes |dir |yes |disabled|
|netcdf_fortran |yes |dir |yes |disabled|
|papi |no |def |unknown |no |
|pfft |no |def |unknown |no |
|triqs |no |def |unknown |no |
|wannier90 |yes |dir |no |disabled|
|xmlf90 |no |def |unknown |disabled|
±---------------±-------±-------±-------±-------+

±-----------------------------------------------------------------+
| CAUTION : Wannier90 is not WORKING ! |
±-----------------------------------------------------------------+
| Action : check your Wannier90 installation |
±-----------------------------------------------------------------+

±-----------------------------------------------------------------+
| Problems must be solved before continuing |
±-----------------------------------------------------------------+

checking that generated files are newer than configure… done
configure: creating ./config.status
config.status: creating fallbacks/INSTALL
config.status: creating fallbacks/README
config.status: creating fallbacks/build-abinit-fallbacks.sh
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing default commands
checking which fallbacks to look for… none
rdutta@ubuntu:~/local/src/abinit-9.6.1/build_gfortran$

~################## this is the conf.ac9########

--------------------------------------------------------------------------

MPI support

--------------------------------------------------------------------------

* the build system expects to find subdirectories named bin/, lib/,

include/ inside the with_mpi directory

with_mpi=$HOME/local/

Flavor of linear algebra libraries to use (default is netlib)

with_linalg_flavor=“openblas”

Library flags for linear algebra (default is unset)

LINALG_LIBS=“-L$HOME/local/lib -lopenblas”

--------------------------------------------------------------------------

Optimized FFT support

--------------------------------------------------------------------------

Flavor of FFT framework to support (default is auto)

The high-level interface does not work yet so we pass options explicitly

#with_fftw3=“$HOME/local/lib”

Explicit options for fftw3

with_fft_flavor=“fftw3”
FFTW3_LIBS=“-L$HOME/local/lib -lfftw3f -lfftw3”
FFTW3_FCFLAGS=“-L$HOME/local/include”

--------------------------------------------------------------------------

LibXC

--------------------------------------------------------------------------

Install prefix for LibXC (default is unset)

with_libxc=“$HOME/local”

Explicit options for libxc

#LIBXC_LIBS=“-L$HOME/local/lib -lxcf90 -lxc”
#LIBXC_FCFLAGS=“-I$HOME/local/include”

--------------------------------------------------------------------------

NetCDF

--------------------------------------------------------------------------

install prefix for NetCDF (default is unset)

with_netcdf=(nc-config --prefix) with_netcdf_fortran=(nf-config --prefix)

Explicit options for netcdf

#with_netcdf=“yes”
#NETCDF_FORTRAN_LIBS=nf-config --flibs
#NETCDF_FORTRAN_FCFLAGS=nf-config --fflags

install prefix for HDF5 (default is unset)

with_hdf5=“$HOME/local”

Explicit options for hdf5

#HDF5_LIBS=nf-config --flibs
#HDF5_FCFLAGS=nf-config --fflags

Enable OpenMP (default is no)

enable_openmp=“no”

#Install prefix of the PSML I/O library (e.g.

/usr/local).

enable_wannier90=“yes”
with_wannier90=“$HOME/local/src/abinit-9.6.1/build_gfortran/fallbacks/install_fb/gnu/9.3/wannier90/2.0.1.1”

Hi,

first , enable_wannier90=“yes” is not defined…

can you try with :

WANNIER90_FCFLAGS=“-I/$HOME/local/src/abinit-9.6.1/build_gfortran/fallbacks/install_fb/gnu/9.3/wannier90/2.0.1.1/include”
WANNIER90_LIBS=“-L$HOME/local/src/abinit-9.6.1/build_gfortran/fallbacks/install_fb/gnu/9.3/wannier90/2.0.1.1/lib -lwannier90”

Hi @jmbgmx,

It does not work. Same message. Could you please send me the instruction for clean fresh installation abinit-9.6.1with the Wannier90 plugins?

Many thanks!
R

Can you send me the config.log file ?

thx

jmb

Hi Jmb,

I have tried with with this config file but no hope
config.log (188.0 KB)
myconf.ac9 (2.3 KB)

thanks!
R

if I remove all the commented lines, here is the ac9 file :

with_mpi="$HOME/local/"

with_linalg_flavor="openblas"
LINALG_LIBS="-L$HOME/local/lib -lopenblas"

with_fft_flavor="fftw3"
FFTW3_LIBS="-L$HOME/local/lib -lfftw3f -lfftw3"
FFTW3_FCFLAGS="-L$HOME/local/include"

with_libxc="$HOME/local"
with_netcdf=$(nc-config --prefix)
with_netcdf_fortran=$(nf-config --prefix)
with_hdf5=$HOME/local

with_fallbacks="yes"
with_libxml2="yes"
with_wannier90="$HOME/local"

There are many problems with this configuration: it can’t work!
The analysis of the config.log file shows that compiled softwares and packages from anaconda3 are used at the same time : it’s not forbidden but it’s very complicated to make a working abinit!

for examples :

  • we ask :

with_hdf5=$HOME/local

and the Build System (BS) of ABINIT finds :

configure:29588: checking for HDF5 library flags
configure:29594: result: -L/home/rdutta/local/lib -lhdf5
  • NetCDF and NetCDF-fortran
configure:39954: dumping NetCDF parameters for diagnostics
...
configure:39966:    * sd_netcdf_prefix = /home/rdutta/anaconda3

BUT

configure:40227: dumping NetCDFF parameters for diagnostics
...
configure:40239:    * sd_netcdf_fortran_prefix = /usr
/usr/bin/ld: warning: libnetcdf.so.15, needed by /home/rdutta/local/lib/libnetcdff.so, may conflict with libnetcdf.so.13

If you want to work under anancond3, it might be easier to subscribe to a channel with ABINIT

https://anaconda.org/conda-forge/abinit